Lyris User's Guide
[previous] [next] [contents]
Problems running Lyris Web Interface
Table of Contents
Introduction
Lyris Email Commands
Web Interface for Users
Server Administrator
Site Administrator
List Administrator
Other Topics
Add-On Packages
Installing and Upgrading
Installing Lyris
Installing Lyris on Unix
Mail Server Coexistence
Upgrading to Lyris from Another List Server
Troubleshooting
Problems running Lyris Web Interface
Problems starting the Lyris Server
Problems with Multiple TCP/IP Addresses
Reinstalled Windows NT, Now Lyris Web Interface No Longer Works
Lyris Does Not Respond to Email I Send it
Finding NT Memory Leaks
Hard Disk Defraggers
Appendix
Frequently Asked Questions

Problems running Lyris Web Interface

If you are having trouble running the Lyris web interface, do the following:

1) check to make sure that your web server is correctly configured to run CGI programs.

2) open on a command window, change directory to the directory with the Lyris web interface scripts. You are looking for a file called "lyris.pl". Once there, enter "perl -v". You should see the text "This is perl, version 5.00x" and some copyright information. Then, enter the command "perl lyris.pl" If you see some HTML codes displayed onscreen, then the problem is likely with your Web server CGI configuration. Consult the section in your web server manual about CGI programs, and Perl programs in particular. If you do not see any HTML, you should have received an error message that should point to the cause of the problem.

Other pages which link to this page:
  • Troubleshooting
  • Page 487 of 556